Updating The Headphone / no sound left


#1

Hi,

my left earbud isn’t working and has never. The descriptions here on the forum seem to be partially by confused The Dash owners, so it’s not quite clear which remedies should work. I’ve however tried a significant number. The two earbuds do not blink synchronously when in the charging cradle, but I waited till both of them were fully lit before trying again, but without luck. I also tried pressing + & - for 5 seconds, but to no avail.

Is there a firmware update available? It seems as if the updater is only for the dash variants. Also, any other ideas what I could do to (re)sync the two?

Thanks


#2

Hi,

Thanks for creating the topic, in order to get rid of the confusion :slight_smile:

Have you tried to contact our Technical Support Team yet? They’re ready to assist you with troubleshooting steps.

Looking forward to hearing from you.

Make it a great day :slight_smile:

Your Team Bragi


#3

Hi @Kristian,

I missed your response here, but I have contacted support via the form on the website a day before I opened this topic. I have yet to receive a response, and tbh, am less than impressed. Response times of two weeks for support requests as well as an apparently frequently non-functioning product do not leave a good impression.

I am not sure how sarcastic you were being in regards to confusion, but the current threads are badly moderated and it’s impossible to gain any understanding. I do not understand how for such a common problem there is not a centralized FAQ with proposed remedies somewhere.

Thanks,

Jonas


#4

Another week without response. Looks like I’ll just throw them in the trash. Color me less than impressed. No reply from support in nearly a month, no public communication about potential self debugging…


#5

Hi,

Thanks for getting back - Apologises for the late response.

The Support Team answers within 24 hours normally! Can you please provide your ticket number, or personal email in order for me to follow up?

Best,
Kristian - Team Bragi


#6

I sent you a PM with my details.


#7

Check your inbox :slight_smile:

Cheers,
Kristian


#8

I received my Dash Pro yesterday. I updated it as per Bragi instructions from 3.0.2 to 3.2.0. I was so excited to get these & use them that I popped them in my ears & I heard nothing. No Ding, No Successful Update, it was nothing but silence. I followed the re-run the update, the reset protocol, & I got nothing but goose eggs. I Placed help request #385314. Any help would be appreciated because I don’t want to send them back.


#9

Hi Adam,

Thanks for reaching out! Our agent Lea came back to you 1 hour ago. Please let us know if you have any further questions! I would recommend having the conversation with her, as she’s our Technical Customer Agent.

Cheers,
Kristian - Team Bragi