The Dash don't work

Hi all. I’ve been given The Dash as a gift, but the earphones are not working.
When I connect them to The Charger (its led is green), they breath in blue and I can see the USB unit in my PC and the left one as well (using a clip for 2 seconds or/and 7 seconds in The Charger).
However, when I put then in my ears I can’t hear any beep or sound. When I shake them, no lights are on indication their battery status.
I’ve tried to update them to BOS 3.2, but the Bragi Updater says they are up-to-date. I’ve tried reload the firmware with Bragi Updater, rapid update (loading the files individually to each Dash), and recovery update (resetting The Charger holding a clip for 7 seconds), but still the same. There is a folder called LOGS with a file CRASHES.TMP in each of them.
I’ve also reset them with The Charger (with a clip for 7 seconds), switched off The Dash completely (holding the clip for about 10 sec) and connect them again to the USB port. Nothing.
I contacted Bragi Support (Karl) and I was asked to delete the TMP files and try the rapid update again in both earphones. The process was as expected (lights blinking in The Dash and then breathing) but it didn’t work. The CRASHES.TMP files appear again. And no sound at all when I put then in my ears.
After that, I was asked to format both earphones with the computer and try again. I did it, but the same result.
The only solution Bragi Support offer is to repair them, but as they are a gift, I have difficulties to get the invoice and I don’t know when they were bought.
When I asked them about if it’s possible to downgrade or install a previous version of the software, they suggested me to post my question in this forum.
Please, any ideas? Could you send me any previous software version to try it? Any way to get some information from the log files to get a clue?
Any help would be very appreciated!!!
Thank you!!


HEy @donkeymac

I’m right here with the same issue lol

I tried updating like hundred times and nothing
I’m trying to get this to work since couple days, and still nothing and I have contacted Bragi support but have yet to receive a response , hopefully this can get resolved I really like this product but is useless for now :pensive:


Thanks for reaching out!

I would like to receive your Case ID, so I can follow up with the Support Team! :slight_smile:

Looking forward to hearing from you.


Hey Kristian!

My Case ID 379744

But unfortunately there is nothing bragi support can do for me they have completed the technical troubleshooting via email with me and they are still not working for me.:frowning: it’s just strange that they can breathe normally when placed in the charger and can mount in the PC and everything but they just don’t respond when placed in the ear.

Hope there is maybe a software solution soon

Did you ever get a fix for this? I read in another forum that if you delete the playlist folders and log folders that worked for them. I will try this later today and let you know how it goes.

1 Like

Hey @Grandarc thanks for reaching out

I haven’t tried anything else since I posted this but that works for you please let me know what ever you did to make them work, mines Are still in the closet lol thanks

So I’m having the same issue as described, Mine are orignal kickstarter editions, and have been sitting in a bag for a couple years which I think is the culprit. I with a fair bit of certainty in my troubleshooting think that the battery in the ear buds are dead. I left the units in the case which were all dead, and they never blinked red like they were charging, they jumped right to blue which to me means they think they are fully charged. the buds work great while they are in the case bu as soon as they are removed there are no signs of life. I too have done a dozen firmware updates, and I noticed when I tried to use the bragi updater it would come to the part to push the pin for 2 seconds to initiate the update, BUT it would never do that, every time I pressed for 2 seconds, it would restart the dash, presumably because there is no battery left to make the headphones work on their own. I don’t know how much they are charging to repair (or more likely replace) but I doubt it will be less hassle than just buying a new set of buds sadly.

1 Like

Hey @Joe_Annunziata I keep having the same issue as you, EXACTLY the same , My pair of Bragi’s are still stuck on my closet for months now without even working as promised. however I don’t know what else to do with them. I let them charge for hours to see if the battery can finally work on their own, but there is no response. If bragi could send me a pair of Batteries or something I could fix them myself hopefully… but… there is no guarantee Bragi will do that, I hope yours can work one day

I have the exact same issue, tried the same resets but no luck, still no sound.

I have the exact same problem. The symptoms of DASH are exactly the same.
when I put then in my ears I can’t hear any beep or sound. When I shake them, no lights are on indication their battery status.
Of course Dash can’t pair with my iPhone.

My case ID is 398628.

Bragi support is no response.
I only look at DASH which became a stone every day.
So sad…

1 Like

Hi, i have the same problem. But it seems like there is no solution. I could see that there is a sysinfo.txt file with information PwrMode=0, what does it mean?

Same problem. Let’s see if any support is forthcoming.

I’d be interested to hear about any progress as well. I have the same issue too. Support are just taking me through the standard processes and getting bored performing them in a slightly different way each time to see if it makes any difference. I have 2 x original Dashes (one unopened from new - breathing in the charger but dead when taken out); the other has the wrong file structure that still isn’t fixed despite resetting multiple time resulting in no ‘My Music’ folder so can’t load mp3’s on to it.

My unit is now 18 months old and just out of warranty. The bluetooth connection has NEVER worked!!! They were a gift for my wife who is not very tech savvy. By the time I had time to try and see what was going on it was too late. After multiple attempts re-setting and downloading software the unit on paper should we working but they will not respond when you put them in your ears and they will not connect via bluetooth.
I have spoken to tech support multiple times but the only answer they have is to re-set and update software which has been done. As they now out of warranty there is absolutely ZERO recourse!
I am extremely frustrated with this purchase and highly recommend that anyone willing to spend this amount of money on ear phones should look elsewhere…

Same issue here.
Green light on charger is fine.
Dash in the charger both breath blue.
Once out of the charger, no lights, sounds, etc…
Was there any real help given by the Bragi team?

Hey @donkeymac, I’ve had the exact same problem! I got my pair of bragi as a gift but they have the same problem: they charge and breath fine in the case but as soon as I take them out and put them in my ears they go completely dead, not sound light or any sign of life. I’ve been talking with Bragi support for a while and they also tell me the same thing: that they cant replace or replace them without proof of purchase.

It really is a shame to see how many people have paid hundreds of dollars for a product that barely functions and @Bragi makes little to no exceptions regarding policy and leaves it’s customers to fend for themselves. It’s embarrassing.

I am sorry to say iit, but Bragi is history. The company sold its entire hardware department to an (obscure) company (, who is now responsible for replacement and repairs. What we have here is the typical problem when a company goes bust…