Mac Book Pro w/ Touch Bar will not connect to my Dash or Dash Pro


#1

For some reason my dash & brand new Dash Pro by Starkey will not mount and show up on my 2016 Mac Book Pro. Had no issues with my previous Mac. It does appear as “Bragi Mass storage” when I check the system information through “About this Mac” but does not show up when using disk utility or on my desk top when connected. I have tried multiple different usb cables to include the original usb cable. Any help or ideas would be greatly appreciated!


#2

i had the problem originally, but I disconnected and reconnected and it worked. I’m using the hyperdrive “dock” with my macbook pro 2016 to allow connection between type A USB 3.0 Bragi DPro and the macbook. It took a about a minute for the unit to mount, but I was ultimately successful. are you using an apple usb type C to type A adapter, or…?


#3

I am using a hyperdrive too. I also bought a USB C to Micro chord to directly connect to my Mac and I still cant get it to connect. I may have to get Mac support to help me.