Left ear won't work despite trying all fixes suggested here

I tried every suggestion here but my left ear won’t work. Please let me know what I have to do to reset everything. My lights do not behave like your Bragi list of commands say. They never blink in sync!

3 Likes

This is the same thing ive experienced and I’ve asked for assistance for over a year.

1 Like

Im in the same boat carvalho… Very disappointing.

I even bought a second pair thinking, the new one will take to update without any issues. Nope. The dang 3.02 IS THE ISSUE.

And support is unable to resolve this problem.

Have you been in contact with the Support Team yet? I would like to see which suggestions that you’ve received! :slight_smile:

If you have a Case ID, please provide it in order for me to help solving the issue.

Best,
Kris

As mentioned to @carvalho, it would be really helpful if you could provide the Case ID from Customer Support in order for me to investigate the troubleshooting and helping you to solve this :slight_smile:

Cheers,
Kris

Kristian,

Please refer to the following tickets.

8/12/2018 - Request# 339761 with Dominic
8/30/2018 - Request# 345465 with Leda
9/5/2018 - Request# 24620936 with Karl then handed over to Leda

Thank you

Hi,

I’ve just checked the case, and Leda have reached out in order to get some information from you.

Can you get back to her as soon as possible, so we can solve the issue? :slight_smile:

Cheers,
Kristian

1 Like

Can i get some help with this

Sure! Do you have any Case ID so I can help you solving it?

Make it a great day :slight_smile:

Kristian

where can i find the case ID for my Bragi The Headphone(truly wireless earphones) ; the left earbud hasn’t been working ever since i got them , i am very annoyed as i have tried all the suggestions and none seems o have helped.

Hi!

Sorry to hear that you’re having issues with your device. You’ll receive a Case ID once you’ve been in contact with our Customer Support. Have you tried to reach out yet?

Best,
Kristian

Hey there! I’m having the same problem with my left ear piece. I updated the right side, the left ear piece won’t charge and isn’t even showing up in my devices when placed in the charger. I tried a reset as well no luck. It’s a shame I have maybe only used these maybe 8 times. If someone could please help it would be most appreciated!

Hi!

Our Support Team are ready to assist you troubleshooting, in order to diagnose the issue.

Can you please create a ticket by sending an email to support@bragi.com?

/ Kristian - Team Bragi