Left Dash Pro Dead?


#1

I just updated my Dash Pros to iOS 3.2 and now my left dash is dead. It has a full charge, is currently accepting a charge but I can’t swipe or tap and change any settings like transparency.

I tried resetting my dash pros using a paperclip on the charging case with the dash pros inside several times and tried putting the dash pros in shipping mode and then setting them back again with no luck.

Anyone have any ideas?? This had happened to me before after another past update but resetting the dash pros in the charging case fixed the problem that time. Now I’m not having any luck with that fix.


#2

Hi Alex,

Sorry to hear about the issues - This is not the way it should be!

I would kindly ask you to contact our Support Team at support@bragi.com, or in the live-chat section at www.bragi.com - So we can troubleshoot and solve the issue.

Looking forward to hearing from you!

Cheers,
Kristian


#3

I actually contacted support but still actually have yet to hear back from them.

I was able to perform a rapid software update procedure since it didn’t seem like the update via the app worked successfully (the same thing happened when I updated to 3.1?) I don’t know if other Dash Pro users are having update issues via the app but for me especially it seems like a problem.

For now however I have happy to say my Dash Pro’s are updated and both right and left are working properly again.


#4

Great to hear!

Let me know if you’re having any issues in the future - We’re here to assist you :slight_smile: