Cannot get left bud to mount

#1

Tried updating The Dash with PC updater, the app connected to the dash app said connected - looking for updates, and hung on that screen. Read into suggestions on website and started rapid update, followed instructions diligently, update for right bud worked perfect. Followed instructions for left bud, but despite several efforts the Dash will not mount, I cannot get the PC to recognize the device and so cannot copy the update file.
I did try PC app again and app reads newest update installed, I try reinstall steps proceed as normal until the step requiring the press of the small button on the dash charger, PC does read the press of the small button on Dash, because it proceeds to next screen saying will start when the Dash is ready and hangs on that screen indefinitely.

Now right dash updated and left is not, and they will not sync together. Both left and right take full charge, there is no dirty or messed up pins on bud or charger. Please help

1 Like
#2

Hi Adam,

Did you manage to solve the issue yet? We’re ready to help you troubleshooting if not :slight_smile:

Let me know.

Best,
Kris

#3

I have the same problem. My bragi updater doesnt work. And i can only update the right bud. The left bud wont mount…regardless of how many times i press the pin hole button. Is there any resolution?

#4

I could not do anything to get my bragis to update with a mac. The left bud would not mount…so the updater wount work and neither would the individual rapid update…i tried it on a pC and it worked…i thnk braig needs to check their mac version of the software…

1 Like
#5

A good tip for others Pete, thanks. I’ve only ever used on a PC myself.