BRAGI The Dash : is not working/connecting


I’m facing a similar issue on my Bragi Dash Pro. The issue happened after BOS 3.2 update. Used Bragi iOS app’s support channel to report the issue and still awaiting a response!!
Was anyone able to make it work??

Here’s the description posted on support channel on IOS app:
Hi ,
I recently updated to BOS 3.2 and setup personalised profile as well.
It worked well for a couple of days but since yesterday it stopped working. Initially it disconnected/connected frequently 3-4times and now it doesn’t connect/‘power ON’.
The 2 blue lights blink and not in sync.
Here’s what I tried so far:

  1. Putting in case so it resets automatically
  2. Charging the case while units in place
  3. Pressing reset button to see if breaths in sync
  4. Reinstalling BOS thru App
  5. Reinstalling ‘old school’ way

Nothing of above works so far.

Appreciate if you could advise how this can be fixed

Recently I tried individual Left/Right dash update as well!!
The only observation I have is during left dash update it blinks ‘bright blue’ and fast, whereas the right dash blinks ‘dull blue’ and fast’

Hope to hear soon from Bragi support… My 3rd Bragi purchase and ending up with similar experience!!


Thanks for the detailed description of the issue! It’s really much appreciated.

I would kindly ask you to check your Case ID, and provide it to me! Or, provide your email so I can follow up personally.

Looking forward to hearing from you! There is a couple of things we can do in order to solve the issue :slight_smile:

Looking forward to hearing from you.



I’m using the Bragi App for the investigation. How to find the case id?
Email id is same as my registered id here.


Hi again,

Can you please provide your email in a DM for me?




I am also facing the similar issue. Any update, how to get dash back to life.



My right dash has done the same thing. After latest update the right dash stopped working. The support team tried all the usual update tricks but nothing worked. They finally told me there is nothing they can do. Highly disappointing. However after reading this it sounds like it may have something to do with the latest update. Any way to look into this?


Same here MM. My second pair and now they are both “bricked”. No matter what procedures (updater or Rapid) nothing seems to work. Left breathes, right has difficulty not breathing and not seen to connect via blue tooth no bling sound when inserted into your ear.

I spend hours with Bragi Support, 2 days, with no positive end result.

I hope this is not happening to everyone. Worst update yet…


Any update on your Dash? Are they still “bricked”, or were you able to find a resolution?


Hi Kory, unfortunately no status change. No resolution found :\


Can you please provide the Case ID once again?

I’ll check it up with the team!



Hi kristian! I would like to ask for help regarding my dash. It’s not working though it’s breathing sync. I aleeady tried to reset but still nothing has change. I tried the shipping mode but it dosen’t work. (I mean the shipping mode, i cant do it). I also tried to long press the right dash so i’ll be able to pair it but still nothing happens. Though it’s dicoverable in my settings when i try to pair it it doesn’t work. Hope you can help me! Thankyou?


I am also having the same issue with the dash not working/connecting. No sound when put them in my ear so no way to connect to bluetooth or even use saved music. Have tried resetting, putting in shipping mode, updating with software, the rapid update process, etc. Bricked. Is anyone getting a resolution?


NO. This is obviously an issue with the latest update. The only resolution I have gotten is “there is nothing we can do”. Basically we are stuck with a bricked $300.00 pair of headphones because their update crashed them. Bragi hasn’t taken responsibility for this yet and if your Dash are out of the one year warranty you might as well throw them away.


Thats disappointing. Does anyone out there have the rapid update files from a previous version saved to their computer still?


In the past I have been able to get to provide previous Bragi OS versions by simply asking.

Kind regards,


Two weeks and they still haven’t replied to any of my emails. Anyone willing to share them on dropbox/google/etc?


Was anyone able to resolve this? My dash pro’s were working just fine and then when I went to update and turned them on they were bricked. The left breathes once in the cradle then stops. The right breathes. I put them in my ear there is no sound at all and won’t respond to touch. I contacted support. They said I needed to reset using the files and them manually (I had done this twice on my own already following the first support person’s advice). They are still bricked :frowning: This is the 3rd set we have owned. The first two were the first edition, thinking maybe they made progress…well looks as though they haven’t.


Mine still are not working as well. This clearly was from the update but Bragi has no answers. I have turned my efforts to do everything I can to make sure no one else wastes money on this product. Thank goodness I have saved several friends so far from throwing their money away on this product. I will recommend the Jabra product. I bought the Jabra ELITE active 65t to replace my $300.00 bricked Bragi’s for half the price. The sound is superior to the Bragi and the fit and feel of these ear phones are excellent. The best thing is that THEY WORK. If you are unfortunate to still be using the Bragi product I would recommend not to update them.


Can you guys please provide your Case ID in order for me to follow up with the Support Team?

Looking forward to hearing from you, we understand how frustrating this must be.



I do not have a case id. I haven’t even received an initial response to either of my inquiries.